Frage:
Raspberry Pi trennt sich vom Netzwerk
vedarthk
2013-03-14 13:32:42 UTC
view on stackexchange narkive permalink

Ich habe Raspbian installiert und eine externe 2-TB-Festplatte über USB mit ext4-Partition angeschlossen. Ich versuche es als NAS-Gerät zu verwenden. Außerdem greife ich über SSH über LAN und auch über das Internet auf Pi zu. Wenn ich über das Internet zugreife, wird die Verbindung zufällig getrennt, und die Lichter auf der Platine blinken weiter. Es wird nicht in der Liste der verbundenen Geräte auf meinem Router Netgear (wnr2000v3) angezeigt. Ich kann nicht herausfinden, was falsch läuft.

Zuerst hatte ich eine Verbindung über Ethernet und habe auch versucht, eine WiFi-Karte zu verwenden, aber der Fall ist der gleiche.

Vielleicht ein Stromproblem? Wird Ihre Festplatte auch von einem eigenen Adapter oder einem fachmännisch betriebenen USB-Hub mit Strom versorgt? Wenn der Strom knapp wird, kann dies zu einem unangenehmen Verhalten führen, anstatt den Pi vollständig herunterzufahren. (Soweit ich weiß, ist die kabelgebundene Netzwerkverbindung als USB-Gerät fest verdrahtet.)
Das USB-Laufwerk verfügt über ein eigenes externes Adapternetzteil.
Kannst du deine Kraft testen? (http://www.rpiblog.com/2012/11/testing-raspberry-pis-power-supply.html)
Ich habe das gleiche Problem. Es ist kabelgebunden mit meinem Router verbunden und die LEDs bleiben an, aber ich kann mich nicht mehr mit SSH anmelden. Ich lasse es kopflos laufen.
Ich habe das Problem möglicherweise gelöst, wie von @RenéWolferink angegeben. Es handelte sich um ein Stromversorgungsproblem. Ich habe einen 5-V-700-mA-Adapter verwendet, der 5-V-1200-mA-Adapter sollte.
Ich hatte das gleiche Problem. Ich habe 5V 1000mA verwendet und die Verbindung wurde immer wieder unterbrochen. Auf 5V 2100mA umgeschaltet und alles ist gut.
Ich bekomme immer wieder zufällige Verbindungsabbrüche von meinem Netzwerk mit "client_loop: send separect: Broken Pipe". Ich habe ein offizielles Raspberry Pi USB-C-Netzteil mit folgenden Spezifikationen: AC 100-240 V 50 / 60Hz-Eingang - DC 5,1 V 3A-Ausgang - 15,3 W maximale Ausgangsleistung. Ist das genug Kraft oder sollte ich eine neue stärkere kaufen? Wenn ja, welches würden Sie empfehlen?
Raspberry Pi 4 übrigens
Zwei antworten:
#1
+4
willer
2015-12-16 14:52:46 UTC
view on stackexchange narkive permalink

Ich hatte das gleiche Problem mit einem 700-mA-Netzteil. Der Strombedarf hängt davon ab, welche Peripheriegeräte angeschlossen sind. Diese Seite Netzteil kommt zu dem Schluss, dass die Verwendung eines 1200-mA-Netzteils eines seriösen Einzelhändlers ausreichend Strom für den Betrieb des Raspberry Pi liefert.

Hallo und Willkommen. Vielen Dank für Ihre Eingabe und hoffen, Sie zu sehen.
#2
+2
Ghanima
2014-09-03 13:59:53 UTC
view on stackexchange narkive permalink

Um die Antworten im Kommentarbereich zusammenzufassen (und eine weitere unbeantwortete Frage zu beseitigen):

Netzwerkabschaltungen wurden auf Probleme mit der Stromversorgung zurückgeführt. Achten Sie daher auf Stromausfälle.

  • 5-V-700-mA-Adapter -> Lösung: 5-V-1200-mA-Adapter
  • 5-V-1000-mA-Adapter -> Lösung: 5-V-2100-mA-Adapter
/ blockquote>

Zum Hinzufügen bearbeiten:

Hier einige Messungen zum Stromverbrauch der verschiedenen Modelle des Pi:



Diese Fragen und Antworten wurden automatisch aus der englischen Sprache übersetzt.Der ursprüngliche Inhalt ist auf stackexchange verfügbar. Wir danken ihm für die cc by-sa 3.0-Lizenz, unter der er vertrieben wird.
Loading...