Frage:
RaspberryPi 3 B +: RPi wird neu gestartet, wenn ich versucht habe, zwei Webcams gleichzeitig auszuführen
Naseeb Gill
2020-01-31 10:16:33 UTC
view on stackexchange narkive permalink

Ich habe ein sehr seltsames Problem mit meinem RPi. Immer wenn ich versucht habe, zwei Webcams gleichzeitig auszuführen, startet sich RPi neu. Vor ein paar Monaten kann ich ohne ein solches Problem zwei Webcams gleichzeitig betreiben (gleiche Kameras und RPi). Ich habe dieses Netzteil verwendet.

Eingangsspannung: AC 100-240 V, 50/60 Hz Ausgang: DC 5,0 V, 2400 mA (2,4 A).

Mit Single Webcam, RPi funktioniert gut.

Was ist das Problem mit RPi? Wie kann ich das korrigieren?

Welche Kameras verwenden Sie und wie viel Strom benötigen sie? Wie hoch ist die Stromstärke des Netzteils? Haben Sie versucht, das rPi auszutauschen? Besteht das Problem mit nur einer angeschlossenen Webcam? Bitte fügen Sie die Antworten in Ihrem Beitrag oben hinzu.
Sir, in Frage stelle ich den Link zu Webcams, die ich benutze. Es ist Logitech C310 HD Webcam. Das Netzteil für RPi ist Eingangsspannung: AC 100-240 V, 50/60 Hz. Ausgang: DC 5,0 V, 2400 mA (2,4 A). Und dieses Problem tritt NICHT auf, wenn nur eine Webcam angeschlossen ist.
Wenn eine Webcam kein Problem hat, tauschen Sie sie aus: Wenn es immer noch kein Problem gibt, wissen Sie, dass das Problem die von zwei Kameras verursachte Last ist. Ein Vorschlag im folgenden Beitrag enthält ein Beispiel für ein USB-Amperemeter zur Messung des aktuellen Bedarfs der Kamera. Sobald der Strom für eine Kamera und die Stromaufnahme für das rPi gemessen wurden, können Sie feststellen, ob Sie mehr Strom von einem Netzteil mit höherer Kapazität benötigen
Vielen Dank für Ihre Zeit. Ich habe gerade ein USB-Amperemeter bestellt und werde Sie über die Ergebnisse informieren. Angenommen, ich habe nach der Analyse herausgefunden, dass RPi mehr Strom benötigen. Dann, wie man dies erhöht. Jetzt verwende ich eine Haushaltsstromversorgung von 220 V über den oben genannten Adapter, dessen Ausgang 5 V bei 2,4 Ampere Strom beträgt.
Seien Sie vorsichtig, wenn Sie auf eine 5-V-Quelle mit 3,0 Ampere aufrüsten. Sie können eine bei eBay oder Amazon (in NYC) kaufen. 3 Ampere sind viel Strom: Stellen Sie sicher, dass die Verkabelung dafür ausgelegt ist, da sonst die Gefahr eines Brandes besteht. Denken Sie daran: Jeder ist hier hilfreich, aber nicht für Ihre Sicherheit verantwortlich.
Ausreichende Leistung. Betrachten Sie einen USB-Hub mit Stromversorgung.
Ich dachte, ich habe gesehen, dass sich die Pis auch selbst neu starten, wenn Ihnen der Arbeitsspeicher ausgeht. Sind wir sicher, dass er nicht zwei hochauflösende Kameras anschließt, die das Board nicht verarbeiten kann? Vielleicht hatte er in der Vergangenheit kein Aufblähen installiert, aber jetzt tut er es, und das erklärt den Unterschied
95% der Probleme sind Macht :-).
@gatorback Ich habe meine Kameras mit einem USB-Multimeter getestet und die Messwerte waren Spannung - (4,70 - 4,87) V und Strom - 0,11 A. Außerdem 189 mAh. Ich denke, Strom ist ausreichend.
@NaseebGill Welchen Strom zieht der Himbeer-Pi? Übrigens, versuchen Sie, das Amperemeter auf den maximalen Strom und den stationären Strom zu beobachten. Ich würde gerne eine Spannung von mindestens 5,0 Volt von der Stromquelle sehen. Mein rPi3B + läuft im eingeschwungenen Zustand mit 5,17 V bei 0,6 A. Greifen Sie auf ein anderes Netzteil zu?
@gatorback Wenn ich nur Himbeer-Pi ohne Kamera-Messwerte anschließe, waren die Spannung - (5,09 V - 5,16 V) und der Strom - 0,64 A. Bei zwei Kameras waren die Messwerte wie Spannung - (4,97 V - 5,13 V) und der Strom - 1,11 A. Ich ziehe an Ich verstehe nicht, was Sie unter "Zugriff auf ein anderes Netzteil" verstehen.
"Zugang zu einem anderen Netzteil" = Verwenden Sie ein anderes Netzteil (vorzugsweise eines, das getestet wurde und als gut bekannt ist).
Fünf antworten:
#1
+9
papatrexas
2020-01-31 14:27:09 UTC
view on stackexchange narkive permalink

Niemand erwähnt, dass die maximale Gesamtstromaufnahme des USB-Peripheriegeräts an einem RPI 3b + 1,2 A beträgt ( Leistungsanforderungen). Allerdings reicht Ihr aktuelles Netzteil aus. Wenn die Kameras tatsächlich jeweils mehr als 600 mA verbrauchen (was ich kaum glauben kann, es sei denn, sie sind zwielichtig), sollten Sie die Option eines USB-Hubs mit Stromversorgung prüfen.

Wenn der [empfohlene Strom für den rPi 2000 mA beträgt] (https://thepihut.com/blogs/raspberry-pi-tutorials/how-do-i-power-my-raspberry-pi), haben die OPs das Glück, dies zu tun Lassen Sie eine Kamera mit seinem 2400-mA-Netzteil arbeiten. Wäre es nicht besser, wenn das OP überprüft (Strommessung), ob jede Kamera den Spezifikationen entspricht und ob die Stromquelle die 3 Geräte mit ausreichend Strom versorgt? Wenn eine der Kameras fehlerhaft ist (zu viel Strom zieht), wie kann er sonst feststellen, welche (falls vorhanden) Kamera fehlerhaft ist?
Ja, natürlich, Kumpel, zu überprüfen, wie viel die Kameras zeichnen, ist eine Selbstverständlichkeit.
#2
+5
gatorback
2020-01-31 10:30:26 UTC
view on stackexchange narkive permalink

Ohne quantitative Beobachtungen kann die Community nur raten. Was ist die Nennstromstärke für das Netzteil? Möglicherweise kann ein Netzteil mit mehr Strom das Problem lösen, wenn die Kameras mehr Strom benötigen als verfügbar.

Wenn nur eine angeschlossene Kamera keinen Reset verursacht, ist der Strom (Stromstärke) insgesamt Wahrscheinlichkeit des Problems.

Sie können die Stromaufnahme der ein und zwei Kameras mit einem Amperemeter messen (Beispiel von eBay):

enter image description here

Und stellen Sie fest, ob Sie genug Strom haben für:

  1. die rPi
  2. Kamera 1
  3. Kamera 2
  4. Wenn Sie diesen Ansatz ausprobieren, teilen Sie uns die Messungen und das Ergebnis mit.

    Update:

    Das OP hat jedoch eine 2400-mA-Versorgung angezeigt :

    Normalerweise verwendet das Modell B zwischen 700 und 1000 mA, je nachdem, welche Peripheriegeräte angeschlossen sind. Das Modell A kann nur 500 mA ohne angeschlossene Peripheriegeräte verwenden. Die maximale Leistung, die der Raspberry Pi verbrauchen kann, beträgt 1 Ampere. Wenn Sie ein USB-Gerät anschließen müssen, das die Leistungsanforderungen über 1 Ampere erfüllt, müssen Sie es an einen USB-Hub mit externer Stromversorgung anschließen.

    Das OP hat das pi-Modell nicht identifiziert: wann Er liefert die Messungen der drei Geräte, dann kann das Problem diagnostiziert und Korrekturmaßnahmen ergriffen werden.

Die meisten dieser Amperemeter messen den Strom nur während des Ladevorgangs. Ich bin nicht sicher, ob sie mit Daten arbeiten werden, die über den Port fließen.
#3
+2
Mike Harris
2020-01-31 23:26:15 UTC
view on stackexchange narkive permalink

RPi ist auch jederzeit unter 5 V spannungsempfindlich. Zusätzlich zur Qualität - dies ist ein Grund, warum die offiziellen Versorgungen auch etwa 5,19 V betragen.

Selbst RPi ohne USB-Peripheriegeräte, aber unter starker Last, können genug Strom ziehen, um die Spannung (zum RPi) zu "bräunen" unter 5,0 V. Ein spontaner Neustart ist eher ein Zeichen für einen Spannungsabfall, da der RPi die CPU drosselt, um die CPU-Temperaturen zu verwalten.

Ein RPi läuft also so gut wie weiter, es sei denn, die Spannung fällt ab. Und sie reagieren ziemlich empfindlich darauf.

Das oben gezeigte USB-Messgerät sollte auch zum Ablesen der Spannung verwendet werden und sicherstellen, dass sie immer größer oder gleich 5 V bleibt. Mit beiden Cams und allen App / Cam / was auch immer Verarbeitung.

Denken Sie auch daran, dass RPi zwar einen maximalen USB-Wert von 1,2 A hat, dies jedoch nicht bedeutet, dass Sie einen RPi (CPU) UND 1,2 A USB ohne USB vollständig laden können Aktualisieren der Versorgung.

Beachten Sie auch, dass 3A per se nicht "gefährlich" ist. Verstärker drücken nicht. Volt drücken. Die Ampere werden basierend auf Volt und Last gezogen. Eine 3A-Versorgung sollte also in Ordnung sein.

Gehen Sie jedoch sofort zu den offiziellen Websites, um zu sehen, wie hoch die maximale CPU-Auslastung ist, testen Sie dies und fügen Sie Ihre 1,2 A für USB hinzu, und das würde Sei dein Minimum. Sehen Sie auch, was die maximale Spezifikation ist (sollte auf einem Blatt im Web stehen).

#4
+1
Dmitry Grigoryev
2020-01-31 19:51:48 UTC
view on stackexchange narkive permalink

Hier ist ein Zitat aus einer Antwort, die Logitech zum Stromverbrauch ihrer Webcams gegeben hat:

[Ein] C310, der Stromverbrauch kann zwischen 50 mA im Leerlauf liegen an alle 500 mA für das Streamen von Videos.

Es ist typisch für USB 2.0-Geräte, immer unter dem Leistungsbudget von 500 mA zu liegen, was ein Maximum ist, das ein vollständig kompatibles Gerät ziehen kann. Daher halte ich es für ziemlich unwahrscheinlich, dass Sie die zulässige Drehzahl von 1,2 A für die USB-Anschlüsse des RPi überschreiten (was bei Überschreitung zu einer Unterbrechung und nicht zu einem Neustart führen sollte) oder die Begrenzung des Gesamtstroms auf 2,4 A (RPi 3B + sollte nicht mehr als verbrauchen) 1A auch bei Volllast).

Sie sollten versuchen, sich daran zu erinnern, was sich seit "vor einigen Monaten" geändert hat, als alles funktioniert hat. Vielleicht ist dieses Netzteil neu und nicht so gut wie in der Spezifikation angegeben (oder einfach defekt)? Vielleicht haben Sie ein neues USB-Kabel, das nicht gut genug ist. Wenn sich die Hardware nicht geändert hat, versuchen Sie, ein Downgrade auf ein älteres Raspbian-Image durchzuführen, und führen Sie kein sofortiges Upgrade durch. Möglicherweise wurde im Treiber oder in der Firmware der Webcam eine Regression eingeführt. Beachten Sie, dass Logitech-Webcams Linux offiziell nicht unterstützen.

#5
  0
Matija Nalis
2020-02-01 22:18:30 UTC
view on stackexchange narkive permalink

Haben Sie immer mehrere bekannte Netzteile von guter Qualität und gute Kabel (hohe Nennstromstärke und vorzugsweise kurze), und probieren Sie zuerst mehrere davon aus.

Kennen Sie auch diese Stromversorgung Netzteile, die für Jahr (e) einwandfrei funktionierten, können schlecht funktionieren - sie sehen immer noch so aus, als würden sie in den meisten Fällen funktionieren, aber bei höherer Last fällt ihre Spannung unter 4,75 V Selbst für eine kurze Zeit, und RaspberryPi startet neu oder einige Teile davon schlagen fehl.

Das ist mir kürzlich passiert. Himbeer-Pi verlor manchmal die Ethernet-Verbindung bis zum manuellen Aus- und Wiedereinschalten (Neustart hat nicht geholfen). Mit dem Multimeter habe ich die Spannung zwischen TP1 / TP2 Testkontakten gemessen, während ich mich größtenteils bei 4,9 V befand die Zeit, manchmal bis zu 4,60 V . Das Problem war die Stromversorgung (bewertet mit 2.4A , die zwei Jahre lang einwandfrei funktionierte und von niemandem berührt wurde, bevor etwas losging). Das neue Netzteil hat das Problem sofort behoben.

Alternativ kann es sein, dass eine Ihrer Kameras fehlerhaft ist und mehr Strom liefert, als sie sollte. Wenn dies der Fall ist und Sie einen dritten haben (oder ausleihen können), können Sie diese paarweise testen ( A + B , A + C , B. + C ), um die fehlerhafte zu isolieren.

Wenn all dies fehlschlägt und Sie zusätzliche Himbeer-Pi und / oder SD-Karte ausleihen können, können Sie versuchen, zu isolieren, wenn das Problem in einer liegt von ihnen.



Diese Fragen und Antworten wurden automatisch aus der englischen Sprache übersetzt.Der ursprüngliche Inhalt ist auf stackexchange verfügbar. Wir danken ihm für die cc by-sa 4.0-Lizenz, unter der er vertrieben wird.
Loading...